Policy Based Routing (PBR) CCNP LAB Guide

Policy Based Routing (PBR) CCNP LAB Guide

Download
Download is available until [expire_date]
  • Version
  • Download 0
  • File Size 522.42 KB
  • File Count 1
  • Create Date November 24, 2024
  • Last Updated November 24, 2024

Here's a detailed lab guide for implementing Policy-Based Routing (PBR) as part of your CCNP studies:


CCNP Policy-Based Routing Lab Guide

Objective:

To configure Policy-Based Routing (PBR) to control the path that packets take through the network based on policies set by the network administrator.

Lab Topology:

  • Routers: R1, R2, R3
  • Network Segments:
    • R1 to R2: 192.168.1.0/24
    • R2 to R3: 192.168.2.0/24
    • R1 to R3: 192.168.3.0/24

Step-by-Step Configuration:

  1. Basic Configuration:
    • Configure IP addresses on all interfaces.
    • Enable routing on all routers.
   R1(config)# interface GigabitEthernet0/0
   R1(config-if)# ip address 192.168.1.1 255.255.255.0
   R1(config-if)# no shutdown

   R2(config)# interface GigabitEthernet0/0
   R2(config-if)# ip address 192.168.1.2 255.255.255.0
   R2(config-if)# no shutdown

   R2(config)# interface GigabitEthernet0/1
   R2(config-if)# ip address 192.168.2.1 255.255.255.0
   R2(config-if)# no shutdown

   R3(config)# interface GigabitEthernet0/0
   R3(config-if)# ip address 192.168.2.2 255.255.255.0
   R3(config-if)# no shutdown

   R3(config)# interface GigabitEthernet0/1
   R3(config-if)# ip address 192.168.3.2 255.255.255.0
   R3(config-if)# no shutdown

   R1(config)# interface GigabitEthernet0/1
   R1(config-if)# ip address 192.168.3.1 255.255.255.0
   R1(config-if)# no shutdown
  1. Configure Routing Protocol (EIGRP):
    • Enable EIGRP on all routers and advertise the networks.
   R1(config)# router eigrp 100
   R1(config-router)# network 192.168.1.0 0.0.0.255
   R1(config-router)# network 192.168.3.0 0.0.0.255

   R2(config)# router eigrp 100
   R2(config-router)# network 192.168.1.0 0.0.0.255
   R2(config-router)# network 192.168.2.0 0.0.0.255

   R3(config)# router eigrp 100
   R3(config-router)# network 192.168.2.0 0.0.0.255
   R3(config-router)# network 192.168.3.0 0.0.0.255
  1. Configure Policy-Based Routing:
    • Create an access list to match the traffic.
    • Define a route map to set the next hop based on the access list.
    • Apply the route map to the incoming interface.
   R1(config)# access-list 101 permit ip 192.168.1.0 0.0.0.255 any

   R1(config)# route-map PBR permit 10
   R1(config-route-map)# match ip address 101
   R1(config-route-map)# set ip next-hop 192.168.3.2

   R1(config)# interface GigabitEthernet0/0
   R1(config-if)# ip policy route-map PBR
  1. Verification:
    • Verify the PBR configuration and ensure traffic is taking the desired path.
   R1# show ip policy
   Interface      Route map
   Gi0/0          PBR

   R1# show route-map
   route-map PBR, permit, sequence 10
     Match clauses:
       ip address (access-lists): 101
     Set clauses:
       ip next-hop 192.168.3.2
  1. Testing:
    • Ping from a host in the 192.168.1.0/24 network to a host in the 192.168.2.0/24 network and verify the path using traceroute.
   Host1> ping 192.168.2.2
   Host1> traceroute 192.168.2.2

This guide provides a comprehensive approach to configuring Policy-Based Routing in a CCNP lab environment.

Spread the word:

Leave a Reply