- Version
- Download 5
- File Size 162.17 KB
- File Count 1
- Create Date July 24, 2024
- Last Updated July 24, 2024
Here's a detailed lab guide for configuring Network Address Translation (NAT) for your CCNA exam preparation:
Objective:
Configure NAT (specifically PAT with overload) on a router to allow internal devices to access external networks using a single public IP address.
Hardware Requirements:
• Two routers with one serial port and two FastEthernet or Gigabit ports each
• One back-to-back DTE/DCE serial cable
• IOS version 12.x or later
• At least one PC running a terminal emulation program
• Cisco console kit
Network Diagram:
PC1 ---- R1 ---- R2 ---- Internet
Step-by-Step Configuration
Step 1: Initial Setup
(i). Erase any existing configurations on the routers and reload them.
(ii). Configure the hostname for each router:
Router> enable
Router# configure terminal
Router(config)# hostname R1
Step 2: Interface Configuration
(i). Configure the interfaces on R1:
R1(config)# interface serial0/1/0
R1(config-if)# ip address 192.1.1.1 255.255.255.252
R1(config-if)# no shutdown
R1(config)# interface gigabitethernet0/0/0
R1(config-if)# ip address 10.1.1.1 255.255.255.0
R1(config-if)# no shutdown
R1(config)# interface gigabitethernet0/0/1
R1(config-if)# ip address 148.1.1.1 255.255.255.0
R1(config-if)# no shutdown
(ii). Configure the interfaces on R2:
R2(config)# interface serial0/1/0
R2(config-if)# ip address 192.1.1.2 255.255.255.252
R2(config-if)# no shutdown
Step 3: Access Control List (ACL)
(i). Create an ACL to permit internal network traffic:
R1(config)# ip access-list standard 1
R1(config-std-nacl)# permit 10.1.1.0 0.0.0.255
R1(config-std-nacl)# permit 148.1.1.0 0.0.0.255
R1(config-std-nacl)# exit
Step 4: NAT Configuration
(i). Define the inside and outside NAT interfaces:
R1(config)# interface gigabitethernet0/0/0
R1(config-if)# ip nat inside
R1(config)# interface gigabitethernet0/0/1
R1(config-if)# ip nat inside
R1(config)# interface serial0/1/0
R1(config-if)# ip nat outside
(ii). Configure NAT overload:
R1(config)# ip nat inside source list 1 interface serial0/1/0 overload
Step 5: Verification
(i). From PC1, test connectivity:
ping 192.1.1.2
(ii). Verify NAT translations on R1:
R1# show ip nat translations
Expected Output:
You should see the NAT translations indicating that internal IP addresses are being translated to the external IP address for communication with the outside network.
This lab guide should help you get hands-on practice with NAT configuration, which is a crucial part of the CCNA exam.